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Why use C/C++ with Matlab?

e Matlab can be slow
e C++ can be fast

— How can we integrate C++'s speed with
Matlab’s convenience?

e Goal:

-Implement critical functions with (fast)
C++ code, and use (slow) Matlab code
for data structure management (which
can be difficult/annoying in C++)



How do we integrate C++ with Matlab?

« Matlab allows the use of MEX files

—MEX files are pre-compiled files
that are called from Matlab

—Can be compiled from Matlab .m
files

—Can also be compiled from external
C++ code.

e This will be our focus



The components of a MEX file

« Every MEX file consists of two parts:

— A gateway routine that interfaces with

Matlab. This is the entry point for the C++
code. Must be called mexFunction()

— Any number of subroutines that are called
from the gateway routine. The bulk of
your computation will be inside these
subroutines.



The components of a MEX file

/ MATLAR ™

A call to
MEX-file func:

[C,D]=FfunciA,B)

tells MATLAE to
pass variables A and
B to your MEX-file.
C and D are laft
unassigned.

o /’
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On return from
MEX-file func:

[C,D]=func(A, B)
plhs[0] is assigned

to Cand plhs[1] is
assigned to O

INPUTS
const mxArray *B
B = prhs[1]

const mxArray *A
A = prhs[0]

func.e

voild mexFunction|
int nlhs, mxArray *plhs[],
int nrhs, const mxArray *prhs[])

In the gateway routine:

# [Tse the mxCreate functions to create
the MATLAR arrave for vour output
arguments. Setplhs[0],[1].... tothe
pointers to the newly created
MATLAEB arrays.

* Ulse the mxGet functiona to extract
vour data from prhs[0], [1], ...

* Call vour C subroutine passing the
input and sutput data pointers as
function parameters.

mxArray *D
D = plhs[1]

NG )

mxArray *C
C = plhs[0]

OUTPUTS

« MEX I/O:

The gateway routine
is passed four
parameters: int

nihs, mxArray

*plhs|[], int nrhs,

mxArrary  *prhs []
nlhs: the number of
outputs

plhs[] : an array of
outputs

nrhs : the number of
inputs

prhs[] : an array of

inputs



Tutorial:

We will create a MEX file to implement a
median filter

.Implemented in C++ using M$ Visual
Studio 2005

*MEX code will be contained in a DLL
(Dynamic-Link Library)



Tutorial:

A

Accessories 3 I n
COE Taols 3

ENENENEnE]

Engineeting Software: ¥
Garmes 3
Mail & Scheduling 3
[} ™ Activestate ActivePerl 5.6 »
Startup L3 |-@ LEGD MINDSTORMS MET 1
Utilies » B Bricx Command Center
Wweb & Web Tools » = Eclipse 3.3
Inkernet Explorér @ Intel{R) Software Ijeve\_opment Tools ¥
Cutlook Express I@ Microsoft \MET Framework SDK v2i0 - »
Windows Messenger ] ) Visual Studio Remote Toals. ;
Caleos ) Visual Studio Tools »
Tour Windows XP
MSH @) Microsoft Yisual Studio 2005 Documentation

Windaws Movie Maker
Wiridaws Media Player

Micrasoft Office 3
: == Microsoft Visual Studio 2005 »
@ Set Program Access and Defaulks windows Poawershel 1.0 »

Adobe Reader &

g! Wwindows Exp\c_m_ar

VisinoWiriter (2
Mews Microsaft OFfice Document deskrop.iri
5 ; TextPad
A Gpen Micrasoft Office Document Virbual ITC
Autedesk ¥

ENENCH 2 IMTETR - [ENENEROT =L AL ~ I35 8 FENENE &

Symanter Client Security 3

2 Documents

Kl

o Settings »

2

g Search »

£

g B 0 add notes
s

= E Shut Dowin..,

I @ 4 7 J (13, Microsaft PowerPaint - [... | ‘,MATI;ABMEX-FiIes—The I &1 mexalkthru rif [Compa...

*Open Visual Studio 2005
eStart->Program Files->Programming Tools
->Microsoft Visual Studio 2005
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Project types:

Templates:

=8 'u'i_sual C++

[#]- Inkel{R) Fortran

[+- Other Languages
[#- Cther Project Types

¥izual Studio installed templates

_5Win32 Console Application

My Templates

~i79earch Online Templates. ..

= Win32 Project

I A praject For creating a Win32 application, consale application, DLL, ar skatic library

j Browse. .. |

Marme; I medianFilter|
| Locatian: I H:\Documentstvisual Studio 2005\Projects
' Solukion Mame: I medianFilter ¥ Create directory For solution

(0] 4 I Cancel |

File->New->Project

Select Visual C++

Select Win32
select win32 project
ename it MedianFilter

*OK
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Win32 Application Wizard - medianFilter ﬂﬂ

= | Application Settings

T

Teed

CIveryismn Application type: Add common header files far:
" Windows application Clam

" Console application ™ wrc

Application Settings

" Static library
Additional options;

I Empty project

I Export symbols

[+ Brecompiled Heatder

< Previous Mext = Finish Cancel

Click "Next’
Select "DLL”
Check "Export Symbols”
Check "Empty Project”
Click “Finish”
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Categaries: Templates:
= \"i_SLIEI| C++ ¥isual Studio installed templates

iU
- Code ] T+ File (.cpp) ] Header Fils {.h)
Data <2 il File: il | Module-Definition File {.def)
Resource ._-%1 Component Class ._-%1 Installer Class
Weh
o Lty My Templates

i Property Sheeks

i Search Online Templates. ..

Creates a file containing Z++ source code

Marne: I mexFunction, cpp

Location: I b Documentsiyisual Studio 20054Projects\medianFilkerimedianFilker Browse, .. |

Add Cancel |

Project->Add New Item
Select "Code”
Highlight "C++ File”
‘Name it "mexFunction.cpp”
Add
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medianFilter Property Pages x|
Configuration: I»‘\EtiVE(DEhLIQ) j FlatForm: IAEtive(W\nSZ) j Configuration Manager. .. |

[#-Cammon Properties Additional Include Directaries
= C_onﬁguratlon Properties Resolve #using References
General Debug Information Format Program Database For Edit & Continue (JZI)
Debugging Suppress Startup Banner ‘es (fnolago)
= ! Warning Level Level 3 (JW3)
- Generel Dekect &4-bit Portabilicy Issues Yes (Jwp6d)
~Optimization Treat Warnings As Errors Mo
Preprocesser ) Use UNICODE Response Files Yes
- Code Generation
-Language
i Precompiled Headers
L OuUtput Files

- Browse Infarmation
i Advanced
- Command Line
[ Linker
[+ Manifest Tool
[#- #ML Dacument Generatar
[#1- Browsse Information
[+ Build Events
[#- Custam Build Step
[#- Web Deployment

Additional Include Directories

Specifies one or more directories to add ko the include path; use semi-colon delimited list if more than one.
(fTpath])

0K I Cancel | Al |

Project->MedianFilter Properties
Expand “Configuration Properties”
Expand “"C/C++"
*Highlight “"General”
Click in the “"Additional Include Directories” field
Click the “..."” buttonz==
«Click the “New Line” button &
Click the “..."” buttonz==
*Browse to “"C:\Program
Files\Mathworks\Matlab\R2007a\extern\include”
OK
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medianFilter Property Pages 2=l
Configuration: IActive(Debug) 'l PlatForm: IActiVe(WinSZ) j Configuration Manager, . |

[ Commaon Properties Additional Include Direckories
B Configuration Properties Resolve #using References
- General Debug Infarmation Farmat Program Database for Edit & Continue {fZI)
- Debuaging Suppress Startup Banner Yes (fnologa)
‘Warning Level Level 3 (JW3)
~ General Detect 64-bit Portability Issues Yes (['Wp64)
+ Optimization Treat Warnings As Errors Mo
- Prepracessor . Use UNICODE Response Files Yes
- Code Generation
- Language
- Precompiled Headers
- Qukput Files
- Browse Information
- Advanced
- Command Line

[#- Linker

[#- Marifest Tool

[#- #ML Document Generakor
[#- Browse Information
[ Build Events

[#- Custom Build Step
[+- web Deployment

Additional Include Directories
Specifies one or more directories to add ko the include path; use semi-colon delimited list if more than one.

{{I[path])

OF I Cancel I Apply |

Project->MedianFilter Properties (CONTINUED)

*Highlight “"Preprocessor”
«Click in the “Preprocé&ssor Definitions” field
Click the “...” button
«Add "MATLAB_MEX_FILE” on a new line
OK

*Highlight "Code Generation”
Change "Runtime Library” to "Multi-threaded
Debug”
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medianFilter Property Pages

Configuration: |ActiV8(Debug) 'l FlatFarm: |Active(Win32)

[=- Common Properties Additional Dependencies
. References Ignore All Defaulk Libraries Mo
[ Configuration Properties Ignore Specific Library
- General Madule Definitian File
-~ Debugging Add Madule to Assembly
- CICH+

Embed Managed Resource File
Farce Symbol References
Delay Loaded DLLs

Assembly Link Resource

#- Custom Build Step
- Web Deployment

Additional Dependencies
Specifies additional items to add to the link line {ex: kernel32.lib); configuration specific,

[o]:4 I Cancel | Apply |

Project->MedianFilter Properties (CONTINUED)
 Expand “Linker”
*Highlight "General”
Change “"Output file” to “"$(OutDir)\MedianFilter.dll”
In the “"Additional Library Directories” field, add:
“C:\Program Files\
Mathworks\Matlab\R2007a\extern\lib\win32\microsoft"
*Highlight "Input”
In "Module Definition File”, add ".\mexFunction.def"
Click Apply
Click OK
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E—"_:Texl:Pad - [H:ADocumentsi¥isual Studio 20051ProjectsimedianFilterimedianFilterimexFunction.def]

© File Edit Search Wiew Tools Macros  Configure  Window  Help
NEE aBELhEl L BER O EE ST D% SR FghE e e
Diocurnent Selector mexFunction.def |

mexFunction, def TLIEBRARY "medianFilter"

EXPORTS
mexFunction

*Add a new text file in your project directory named
“mexFunction.def”
*Add the following lines:

LIBRARY “MedianFilter"
EXPORTS
mexFunction
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*Project->Add New Item
*Select “Code”
*Select “Header File”
*Name it “mexFunction.h”
*Add

*Add the following lines to your new header file:
#include "matrix.h”

#include "mex.h”
#define MEX_FUNCTION_EXPORTS

#ifdef MEX _FUNCTION_EXPOR

#define MEX_FUNCTION_API _ declspec(dllexport)
#else

#define MEX_FUNCTION_API _ declspec(dllimport)
#endif

MEX FUNCTION_API void mexFunction(int nlhs,
mxArray* plhs[],int nrhs, mxArray* prhs[]);
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In your .cpp file, add the following lines:

#include "mexFunction.h”

#pragma comment(lib, "libmx.lib")
#pragma comment(lib, "libmat.lib")
#pragma comment(lib, "libmex.lib")

*Check that what you’'ve done so far will
compile. Of course, it won’t do anything, but
it's good to check for errors.



Tutorial:

We're now in a position to actually start coding.

Let’s start with our gateway function,
mexFunction().

*Add the following lines to your file:

void mexFunction (int nlhs , mxArray *
plhsl], int nrhs, mxArray *prhs[])}{

}

*This defines the entry point for our program,
and declares the four variables that we will
need to talk to Matlab.
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*We should decide what we will be
passing in, and what we will be passing
back. We're implementing a median filter
to process an image, so what will our
inputs be? Obviously, we'll need an input
image. We could also define an arbitrary
filtering radius, but that would makes
things a little more complicated. Let’s
keep it simple: we’ll pass a matrix in, and
we’'ll pass the filtered matrix back out.



Tutorial:

*Thus, for our function:
nlhs =1

nrhs =1
prhs [0 ] is the input image,
plhs[O] is the output image.



Tutorial:

Where to start? Let’s take care of the

input matrix first. Define a pointer to a
matrix of type mxArray :

mxArray *matrixin;

Where should this pointer point? Well,
how about our input image?

matrixIn = prhs[0];
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We're working with a 2D array (an
image),but it is stored as a 1D array.
Thus, it will probably be useful to know
where our row and column bounds are.
We can get the size of our mxn matrix
with:

m = mxGetM(matrixin);

n = mxGetN(matrixin);

Now, the (i,j) element of the image is at:

Image[(m*)+]
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Ok. Now we’'ve taken care of the input
matrix. Let’s define an output matrix of the

same size as the input matrix.
Remembering that plhs|[0] is a reference

to the output matrix, we can do this with:

plhs[0] =
mxCreateDoubleMatrix(m,n,mxREAL);



Tutorial:

Now we’re in a position to write our MedianFilter()
function. If we weren’t dealing with Matlab, we could call
it with:

MedianFilter(&matrixin, &matrixOut, m, n);

We're in Matlab-land now, however, so instead of the
“address-of” operator (&), we need to do the following:

MedianFilter(mxGetPr(matrixin),
mxGetPr(plhs[0]), m, n);

The mxGetPr() function returns the address of the first
element of the matrix.



Tutorial:

Let’s write our MedianFilter() function.

We are passing by reference (thus our
function doesn’t return anything) so it’s of
type void . We are passing it the addresses
of two matrices of type double , so we
declare our first two input arguments as
double* . We are also passing it two
integers, so putting everything together, we
have:



Tutorial:

vold MedianFilter(double * imageln ,
double* IimageOut, iInt m, Int n){

}

Make sure you add a function prototype to
your header:

void MedianFilter(double *,
double*, int, Int);
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Now for the actual algorithm. we’ll begin our loop at
three so that we don’t need to worry about what to do
when our kernel is close to the borders. If we format our
input image correctly in Matlab, everything will work out
fine...

vector<double> neighborhood,
double median;
Int u,v,i,;

//matlab stores matrices by column, so it's
//most efficient to have our outer loop parse
//through rows, and our inner loop parse
//through columns(i.e. * not * //like you're
//reading English)
for(i=3;i<n-2;i++){

for(j=3;j<m-2;j++){
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//lconstruct the new neighborhood:
/[first, reset the vector
neighborhood.clear();

//get the five horizontal elements
for(u=i-2;u<i+3;u++) {

neighborhood.push_back(imageln[(m*u)+j] );
}

//get the two top elements
for(v=j-2;v<j;v++){
neighborhood.push_back(imageln[(m*i)+V] );

}

//get the two bottom elements
for(v=j+1,v<j+3;v++){
neighborhood.push_back(imageln[(m*i)+V] );

}
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//we now have a 9 pixel neighborhood...

//first, sort the neighborhood
sort(neighborhood.begin(), neighborhood.end());
//now pick out the median:

median = neighborhood[4],

//assign the current pixel to the median
ImageOut [(m*I)+]] = median,;
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Let’s see if this compiles. Nope. We forgot to
include some things:

#include <vector>
#include <algorithm>

using namespace std,

Now it should compile. We should probably call

our function at some point, so stick this at the
bottom of mexFunction():

MedianFilter( mxGetPr(matrixin),
mxGetPr(plhs[0]), m, n);



Tutorial:

Good. We're done with the C++ side
of things. Now we need to write the
Matlab side of things. Start up Matlab
and start a new .m file. This .m file
only needs one line:

Function filtered =
MedianFilter(l);
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Save it as MedianFilter.m in the
same directory that Visual Studio
wrote the .DLL file (should be
“<project directory>\
medianFilter\Debug\”). Now

create another .m file, name it
test.m or something of the sort.



Tutorial:
Make your test.m file look like this:

%read In a test Image
| = imread('medlines.qgif');
dim =size(l);  %get the size

%pad the image with 4 pixels
J = zeros(dim+4);,
J(3:dim(1)+2,3:dim(2)+2) = I;
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%take care of padding our extra 4
columns

J(:,1) = J(:,4);

J(:,2) = J(:,3);

J(;,dim(2)+3) = J(;,dim(2)+2);
J(;,dim(2)+4) = J(;,dim(2)+1);

%take care of padding our extra 4 rows
J(1,:)) =J@4,);

J(2,:)) = J(3,));

J(dim(1)+3,:) = J(dim(1),:);
J(dim(1)+4,:) = J(dim(1)-1,:);
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%pass our padded image to MEX
routine
K = MedianFilter(J);

%throw away the padding
K =K(3:dim(1)+2,3:dim(2)+2 );
iImshow(K,[0 255]); %show it

clear mex %useful for debugging



Tutorial:

Now make sure that your test image is in the same folder
as the other files, and run your test.m script. If

everything went according to plan, you should see your
processed imag pop up.

One advantage of th|s median ﬁlter is that it is edge-

preserving. If your function worked correctly, you should
still see the white lines in the image.



Exercise:

Modify this example to implement a 5x5
averaging filter. Thus, each pixel of the
output image should contain the average
value of the corresponding 5x5 region of
the input image.



